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The aim of the work 
 

 The presented methodological guidelines are developed for full-time foreign 
students education level «bachelor» specialty 191 – Architecture and town-planning, 
192 – Building and Civil Protection. 
 The transformation of the world construction industry in recent years has 
been marked by the introduction of Building Information Modeling (BIM) 
technology. These technologies use a public information database consisting of a 
collection of library elements, each of which is presented in digital form and 
describes all the functional and physical properties of building objects. 
 The aim of the work to teach the students use opportunities of the specialized 
software product REVIT for creating a 3D building model. Teach using 3D libraries 
of structural elements: interior walls, doors, windows, exterior walls, floor slabs, roof 
elements, ceilings, floors using and in accordance with the requirements of existing 
DBN with customized annotations, analytical and other necessary. 
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1. Creation of a new architectural project 
 Create an architectural project. The easiest way is to click the Architecture 
Template button located on the left side of the project area in the Recent Files 
window. The second way is to click the New button in the same place or execute the 
command Create -> Project, located in the application menu (Fig. 1). 
 

 

 

Figure 1 – Application menu 

 If you use the second method, the New Project window opens (Fig. 2). To 
select a template, expand the Template File drop-down list. To load a template that is 
not available in this menu, the Browse button is used. In the Create New area, you 
specify what exactly we are creating – Project or Project Template. In our case, you 
must select the Architectural template and tick the Project. 
 
 

 

Figure 2 – New Project 
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2. Specifying axes and levels 
 Double-click on the LMC in the project manager and go to the Construction 
site plan (Fig. 3). 
 

 
 

Figure 3 – Construction site plan 
 
 Activate the command Architecture -> Base -> Grid (Fig. 4). 
 

 

Figure 4 – Grid 

 Activate the Edit | Coordinates grid -> Draw -> Line (Fig. 5). 
 
 

 

Figure 5 – Line 
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 Draw an axis 1 in the drawing area (Fig. 6). 

 

Figure 6 – Axis 1 

 

 Activate the Edit | Coordinates grid -> Drawing -> Select lines (Fig. 7). 
 
 

 

Figure 7 – Select lines 

 On the Options panel in the Offset window, set the offset value to 3000  
(Fig. 8). 
 

 
 

Figure 8 – Offset window 
 
 Move the cursor to the 1 axis in such a way that a blue dashed line appears on 
the right, and click the LMB (Fig. 9-1). The axis 2 will be built (Fig. 9-2). Build the 
axes 3 and 4 in the same way (Fig. 9-3). 
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Figure 9 – Build the axes 
 

 Construct an axis perpendicular to the axes 1-4 (Fig. 10). 
 

 
Figure 10 – Construct an axis 

 
 Click on the LMB along the 5 axis, and then on the mark (Fig. 11-1). Change 
the marking to the Russian letter A (Fig. 11-2 and 11-3). Click Spacebar or click 
LMB in any free place in the drawing area (Fig. 11-4). 
 

 
Figure 11 – Mark axis A 
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 Repeating and construct the B, G and D axes (Fig. 12). 

 
 

Figure 12 – Mark axis B, G and D 
 

 By successive clicks of the LMC along the axes from the 1st to the 5th, 
measure them (Fig. 13-1). With the last click in any free place in the drawing area, 
apply the dimensions. Lock the resulting dimensions by clicking on the icons in the 
form of open locks (Fig. 13-2 and 13-3). Set the size between axes 1 and 5 (Fig. 13-
4). 
 

 

Figure 13 – Dimensions horizontal 
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 Analogously dimension the axes A, B, C and D (Fig. 14). 

 
 

Figure 14 – Dimensions vertical 
 
 Double-click in the project manager, go to the East facade (Fig. 15). 
 

 
Figure 15 – East façade 
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 Rename Level 1 to Floor 1 (Fig. 16-1), Level 2 to Mansard (Fig. 16-2). On 
the question Rename the relevant species? answer in the affirmative. Change the 
height of the Mansard level (Fig. 16-3). 
 

 
 

Figure 16 – Rename 
 
 Click the LMB axis (Fig. 17-1). On the Properties palette, click Change Type 
(Fig. 17-2). In the Type Properties dialog box that appears, in the Notation line that is 
not relevant to the plan view, expand the drop-down list and select Bottom  
(Fig. 17-3). 
 

 

Figure 17 – select Bottom 
 

3. Walls 
 Go to Floor 1. Activate the tool Architecture -> Formation -> Wall (Fig. 18). 
 

 
Figure 18 – Wall 
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 In the options pane, select Height and Non-Connected in the drop-down list, 
in the window, write down 8000, check the Chain. Expand the Bindings drop-down 
list: and select Clarity surface: Interior (Fig. 19). 
 

 
 

Figure 19 – Surface Interior 
 
 On the Properties palette, expand the list of dimension types and select Wall 
with air gap CW 102-50-100p (Fig. 20). 
 

 
 

Figure 20 – select Wall 
 

 Construct an outer wall, successively clicking on the LMC along the 
intersections of the axes (Fig. 21): 
• Г and 1; 
• Г and 4; 
• A and 4; 
• A and 1; 
• again Г and 1; 
• Press Esc. 
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Figure 21 – Intersections of the axes 

 
 Use the Properties palette to select the Typical Size – 200 mm (Fig. 22). 
 

 
Figure 22 – Select the Typical Size 
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 In the options panel, select the Mansard item in the drop-down list (Fig. 23). 
 

 
 

Figure 23 – Options panel 
 
 Draw the inner walls. For this purpose (Fig. 24): 
- click the LMB in sequence to intersect the B and 4 axes and the B and 1 axes; 
- press Esc; 
- click the LMB in sequence to intersect the axes B and 4, the axes B and 3 and the 
axes A and 3; 
- press Esc. 

 

 

Figure 24 – Inner walls 
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 If you need to turn the wall, then you need to select it and click on the icon in 
the form of two arrows (Fig. 25). 

 
Figure 25 – Turn the wall 

 
Go to the Attic plan. Activate the Wall tool. In the options panel, in the drop-down 
list, select Non-connected, height – 6000 (Fig. 26). 
 

 
 

Figure 26 – Select Unconnected 
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 Draw the inner walls of the attic (Fig. 27). 

 
 

Figure 27 – Inner walls of the attic 
 
 To align the wall between axes 2 and 3, do the following: 
- activate the command the parallel dimension; 
- sequentially click the LMC axis 2, wall and axis 3 (Fig. 28-1); 
- take out the size beyond the wall and apply it (Fig. 28-2); 
- Click the icon with the letters EQ crossed (Fig. 28-3). 
 

 

Figure 28 – Align the wall 
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4. Overlapping 
 Go to Floor 1. Activate the tool Architecture -> Formation -> Overlap -> 
Overlap: architectural (Fig. 29). 

 
Figure 29 – Select Architectural 

 
 Activate the Edit | Create a floor array -> Draw -> Select lines (Fig. 30). 

 
Figure 30 – Select lines 

 
 Move the cursor to the outer surface of the outer wall of the axis 1. It lights 
up in blue, click on the LMB (Fig. 31-1). The first section of the overlapping contour 
appears, lock it (Fig. 31-2). Construct the remaining segments. Leave only the 
segment of the A axis unblocked (Fig. 31-3). 
 

 
 

Figure 31 – Remaining segments 
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Activate the Edit | Create a floor array -> Draw-> The line (Fig. 32). 
 

 
Figure 32 – The line 

 
 Construct three segments (Fig. 33). 

 
Figure 33 – Segment 

 
 Activate the Edit -> Draw -> Split Element tool (Fig. 34). 

 
Figure 34 – Split Element tool 

 
 Hover the cursor to the center of the line of the A axis and click the LMB to 
split it (Fig. 35). 

 
Figure 35 – Split line 
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 Activate the tool Edit -> Draw -> Trim / Extend to the corner (Fig. 36). 
 

 
Figure 36 – Extend to the corner 

 
 Click on the line segment as shown in Fig. 37-1 and 37-2. Unnecessary 
stretches are cut off, the result is displayed in Fig. 37-3. 

 
Figure 37 – Unnecessary stretches 

 
 Activate the Edit -> Draw -> Align tool (Fig. 38). 

 
Figure 38 – Align tool 

 
 Click along the axes and segments, as shown in Figure 39-1 and 39-2, which 
would align the segments relative to the axes (Fig. 39-3). 
 

 
 

Figure 39 – Align the segments 
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 Click the LMB along the segment between axes 2 and 3, the time dimension 
appears, click on it LMC and change it to 1500 (Fig.40). 

 
Figure 40 – Change segment 

 
 Complete the overlay sketch by clicking Edit | Create a floor array -> Mode -
> Exit the editing mode (Fig. 41). 

 
Figure 41 – Exit the editing mode 

 
 The result should look like in Figure 42. 
 

 
Figure 42 – Building result  
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 Go to the Attic plan. Activate the tool Architecture -> Formation -> Overlap -
> Overlap: architectural. 
 Activate the Edit | Create a floor array -> Draw -> Select walls (Fig. 43). 
 

 
 

Figure 43 – Select walls 
 

Move the cursor to one of the walls. Press Tab. The whole chain of walls will 
be illuminated. Click the LMB on the wall (Fig. 44-1). A contour of overlap will be 
created along the perimeter of the walls (Fig. 44-2). 

 

 
 

Figure 44 – Contour of overlap 
 
 The result should look like in Figure 45. 
 

 
 

Figure 45 – Building result 
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5. The roof 
 Go to the Attic plan. Activate the command Architecture -> Formation -> 
Roof -> Roof over the contour (Fig. 46). 

 
 

Figure 46 – Roof over the contour 
 
 On the Properties palette, expand the list of dimension types, and select 
Typical – 400mm (Fig. 47). 

 
 

Figure 47 – Select Typical 
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 On the Properties palette in the Offset from the level row, set the offset to 
1000 (Fig. 48). 

 
Figure 48 – Set the offset 

 
 Activate the Edit | Create a contour of the roof -> Draw -> Rectangle  
(Fig. 49). 

 
 

Figure 49 – Rectangle 
 
 Circle the outer walls of the rectangle (Fig. 50). 

 
Figure 50 – Circle the outer walls 
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 Using the time dimensions for each section of the contour, set the distance 
from the outer contour of the wall to 400 mm (Fig. 51). 

 
Figure 51 – Section of the contour 

 
 Using Ctrl, select the segments along the axes 1 and 4 (Fig. 52)  
 

 
 

Figure 52 – Select the segments 
 
 Complete the overlay sketch by clicking Edit | Create a roof contour -> Mode 
-> Exit the editing mode. The program will ask the question, answer «yes» in the 
affirmative. 
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6. Windows 
 Go to Floor 1. Activate the tool Architecture -> Formation -> Window  
(Fig. 53). 
 

 
 

Figure 53 – Formation 
 
 Click Edit | Coordinates Window -> Mode -> Load family (Fig. 54). 
 

 
Figure 54 – Coordinates Window 

 
 In the window that opens, navigate to the Windows folder and load the 
Double-down double-trimmed window family (Fig. 55). 
 

 
Figure 55 – Window famil 
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 On the Properties palette, in the list of dimension types, select  
1220 × 1220 mm (Fig. 56). 
 

 
 

Figure 56 
 

 Hover the cursor over the wall, as shown in Figure 57-1 and click the LMB. 
The window will be installed (Fig. 57-2).  
 

 
 

Figure 57 – Installed window 
 
 After activating the Parallel size command, align the window with respect to 
axes 1 and 2 (Fig. 58). The blue line in the center of the window will appear when 
you hover over the center of the cursor. 
 

 
 

Figure 58 – Installed window in the center 
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 Arrange and align the windows as shown in Figure 59. 

 
Figure 59 – Arrange and align the windows 

 
 Go to the Mansard plan, arrange and align the windows as in Figure 60. 

 
 

Figure 60 – Arrange and align the windows on the Mansard plan 
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7. Doors 
 Go to Floor 1. Activate the tool Architecture -> Formation -> Door (Fig. 61). 
 

 
 

Figure 61 – Formation 
 
 Download the Single-Decorative 2 family (the Doors folder), and on the 
Properties palette in the list of dimension types, select 0915 × 2134 mm. 
 Align and align the doors between axes 2 and 3 on the wall of the A-axis  
(Fig. 62). 

 
Figure 62 – Align the door 
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 On the Properties palette, in the list of dimension types, select Single-Shield -
> 0915 × 2134 mm. 
 Align and align the doors as shown in Figure 63. If it is necessary to turn 
them over. You can turn them over by pressing the Spacebar during installation. 
 

 
Figure 63 – Align the doors 

 
 Go to the Mansard plan, install and align the doors, as in Figure 64. 

 
Figure 64 – Align the doors on the Mansard plan 
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8. Stairs 
 Go to Floor 1. Activate the tool Architecture -> Movement -> Ladder -> 
Ladder by component (Fig. 65). 
 

 
 

Figure 65 – Ladder by component 
 
 On the Edit | Create a ladder in the Components panel, activate the Span and 
Straight tools (Fig. 66). 
 

 
 

Figure 66 – Components panel 
 
 Make sure that the properties palette is set to the parameters, as in Figure 67. 
 

 
Figure 67 – Parameters 
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 Click on the LMB as in Figure 68-1 and move the cursor to the right. On the 
screen there will be a ladder, below – an inscription. Click the LMB the second time, 
when it tells 9 PENDANTS CREATED, 9 REMAIN. Repeat this procedure for the 
second part of the ladder (Fig. 68-2) by clicking the second time the message says 9 
PENDANTS CREATED, 0 REMAINED. 
 

 
 

Figure 68 – Draw the stairs 
 
 Run the Edit | Create a ladder -> Tools -> Guard (Fig. 69). 
 

 
 

Figure 69 – Tools 
 
 In the drop-down list of the window that opens, select Glass panel – fill from 
the bottom. In the Location area, select Kosower / Stitch (Fig. 70). 
 

 
 

Figure 70 – Kosower / Stitch 
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 Delete the elements highlighted in Figure 71. 
 

 
 

Figure 71 – Elements highlighted 
 
 Select the whole ladder with the frame (Fig. 72-1). Activate the Edit | Create 
a ladder -> Edit -> Move (Fig. 72-2). Click the LMB's bottom right corner of the 
selected group (Fig. 72-3). Click the LMB corner formed by the walls in the axes 4 
and B  
(Fig. 72-4). 
 

 
 

Figure 72 – Walls in the axes 
 
 Activate the Align tool. Click the LMB in succession on the A axis and the 
edge of the ladder nearest it (Fig. 73). 
 

 
 

Figure 73 – Align tool 
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 Select the outer enclosure of the ladder (Fig. 74) and remove it. 
 

 
 

Figure 74 – Outer enclosure of the ladder 
 
 If you select the inner staircase guard (Fig. 75-1) on the Edit | The Guard 
appears button Show Alerts (Fig. 75-2), on the Properties palette, click the Change 
Type button. In the Type Properties window, click the Modify button in the Placing 
Balusters line (Fig. 75-3). In the Edit Balancing Layout window (Fig. 75-4), in the 
Fence Fence at the intersection of Line 2 and Top boxes, expand the drop-down list 
and select the Element of the upper handrail (Fig. 75-4). Do the same in the Racks 
table for all three rows (Fig. 75-4). 
 

 
 

Figure 75 – Inner staircase guard 
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 Go to the Attic plan. Select the rectangle with all the elements of the model 
(Fig. 76-1). Click Edit | Select multiple -> Select -> Filter (Fig. 76-2). In the Filter 
window that opens, delete all the checkmarks except Overlap and click OK  
(Fig. 76-3). Only the overlap of the attic will be allotted (Fig. 76-4). 
 

 
Figure 76 – Overlap of the attic 

 
 Click Edit | Overlapping -> Mode -> Edit border (Fig. 77). 

 
Figure 77 – Edit border 

 
 Edit the boundary of the path as shown in Figure 78, and exit the edit mode. 
Answer the question in the affirmative. 

 
Figure 78 – Boundary of the path 
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9. Fences 
Activate the tool Architecture -> Motion -> Protections -> Sketch trajectory (Fig. 79). 

 
Figure 79 – Sketch trajectory 

 
 On the Properties palette, in the list of sizes, select Glass panel – fill from the 
bottom. 
 Draw a fence outline (Fig. 80) and exit the sketch mode. 

 
Figure 80 – Fence outline 

 
 Go to floor plan 1 and form the fences near the front door as in Figure 81. 
 

 
 

Figure 81 – Form the fences  
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 Open the 3D view with the command View -> Create -> 3D View -> 3D 
view by default (Fig. 82). 
 

 
 
 

Figure 82 – Command View 
 
 A view similar to Figure 83. 
 
 

  
 
 
 

Figure 83 – 3-D drawing of buildin 
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10. Canopy above the entrance 
 Activate the tool Architecture -> Formation -> Roof -> The roof is extruded 
(Fig. 84). 
 

 
 

Figure 84 – Formation of Roof 
 
 In the Workplane window that opens, in the Specify working plane area, 
select Select plane (Fig. 85-1). After closing the window, select the outside of the 
wall on which the entrance door is located (Fig. 85-2). In the window that appears, 
specify the level of the attic and the mixture of 0 (Fig. 85-3). 
 

 
Figure 85 – Entrance door 

 
 Go to the South facade. 
 On the Properties palette, in the list of sizes, select Typical – 125 mm. 
Activate the Edit | Create a roof profile formed by extrusion -> Draw -> Arc along 
the center and end points (Fig. 86). 

 
Figure 86 – Place lines 
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 Draw an arc in such a way that the center is located in the center of the 
horizontal upper segment of the door, and the end points on the axes 2 and 3 (Fig. 
87). 
 

 
 

Figure 87 – Drawing arc 
 
 On the Properties palette in the Beginning extrusion and End extrusion lines, 
type 0 and -1500, respectively (Fig. 88). Finish work. 
 

 
 

Figure 88 – Properties palette 
 
 The first draft is ready. Go to the {3D} view. In the View Control Panel, 
expand the Visual Style drop-down list and select Realistic. Now you can rotate the 
model using the view cube or the steering wheel. 
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 To see the ladder, on the 3D view, click the LMB on the wall in axis 4  
(Fig. 89). After its selection, click on it PKM (Fig. 90). The wall will disappear  
(Fig. 91) and a ladder will be visible (Fig. 92). 
 

 
 

Figure 89 – The ladder on the 3D view 
 
 

 
 

Figure 90 –  After its selection 
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Figure 91 – The wall disappeared   
 

 

 
 
 

Figure 92 – The ladder is visible  
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