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IN THE «3D MODELS IN GOOGLE EARTH» PROJECT 
 

Boris Bocharov, Maria Voevodina 
 
Many users from around the world create the three-dimensional models in 

Google Earth. Anyone can add their own models – it's very exciting! You can 
create a model using a program Google SketchUp, the best free program of 
three-dimensional modeling 

There is a project «3d models in Google Earth» in our University. Start your 
acquaintance with the project on the home page of distance learning [1-8]. 

 
All the models you can see in the internet. 
 

 
 

All three-dimensional models of Kharkov National University 
of Municipal Economy students in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=81b5cc5f4d70265612a4187324fb8b1b 

 
 

Kharkov National University of Municipal Economy students 
and faculty project "My School in Google Earth" 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=af4d9bf06e7283659cf8f2709381923e 

 
 

Kharkov National University of Municipal Economy Objects in 
Google Earth  
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=6335b17c1e6cfa4eedf468ea8a9d1b70 

 

Geomodel of Kharkov National University of Municipal 
Economy students in Google Earth. Models from the 
collections of "My School in Google Earth" and "Kharkov 
National University of Municipal Economy in Google Earth" 
are not included 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=efd35b4688fa71e12a4187324fb8b1b 
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Three-dimensional models of Kharkov city buildings, created 
by students of Kharkov National University of Municipal 
Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=49565b54b26978434736748a1dce4da3 

 
 

Three-dimensional models of Kharkov region buildings, 
created by students of Kharkov National University of 
Municipal Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=accd4e8d194fddb04736748a1dce4da3 

 
 

Three-dimensional models of Poltava Region buildings, 
created by students of Kharkov National University of 
Municipal Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=69a7f199fd27d12933c06e4d24f8e1e0 

 
 

Three-dimensional models of Lugansk Region buildings, 
created by students of Kharkov National University of 
Municipal Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=784ecac4da3ca0194736748a1dce4da3 

 
 

Three-dimensional models of Donetsk Region buildings, 
created by students of Kharkov National University of 
Municipal Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=152428722ff994004736748a1dce4da3 

 
 

Three-dimensional models of Nikolaev Region buildings, 
created by students of Kharkov National University of 
Municipal Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=4cc324d0cd8aaa3ee689ff416cc497b3 

 
 

Three-dimensional models of Crimea buildings, created by 
students of Kharkov National University of Municipal 
Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=52f473f5997d31a54736748a1dce4da3 
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Three-dimensional models of Zhitomir Region buildings, 
created by students of Kharkov National University of 
Municipal Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=25a119452a7a69aa4736748a1dce4da3 

 
 

Three-dimensional models of Sumy Region buildings, 
created by students of Kharkov National University of 
Municipal Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=8a33d1b2ce262ed300ee41ef10e933f 

 
 

Three-dimensional models of Zaporozhye Region buildings, 
created by students of Kharkov National University of 
Municipal Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=550e66427bc9bf14736748a1dce4da3 

 
 

Three-dimensional models of Chernovtsy Region buildings, 
created by students of Kharkov National University of 
Municipal Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=d865e367b5344ed74736748a1dce4da3 

 
 

Three-dimensional models of Dnepropetrovsk Region 
buildings, created by students of Kharkov National University 
of Municipal Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=f2ffacefd992a9804736748a1dce4da3 

 
 

Three-dimensional models of Russia, created by students of 
Kharkov National University of Municipal Economy in Google 
Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=f54858cafe1a944c4736748a1dce4da3 

 
 

Three-dimensional models of USA buildings, created by 
students of Kharkov National University of Municipal 
Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=feedb3d6fafe031633c06e4d24f8e1e0 
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Three-dimensional models of Morocco buildings, created by 
students of Kharkov National University of Municipal 
Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=91ddaaffb604d710dfcb60db357a3652 

 
 

Three-dimensional models of Egypt buildings, created by 
students of Kharkov National University of Municipal 
Economy in Google Earth 
http://sketchup.google.com/3dwarehouse/cldetails? 
mid=cd4892194e9aa3abe689ff416cc497b3 

 
SketchUp (a Trimble product) is designed to be simple and easy to use. 

The main parts of the SketchUp interface are the Title bar, menus, toolbars and 
tool palettes, drawing area, Status bar, and the Measurements toolbar. The 
following images show the SketchUp user interface. 

 
Title Bar 
The title bar, at the top of SketchUp, contains the standard window controls 

(close, minimize, and maximize), the name of the currently opened file, and a title 
bar collapse/expand button on the right (Mac only). A blank drawing area appears 
when you start SketchUp and the name of the currently opened file is "Untitled" in 
the title bar, indicating that you have not yet saved your work. 

 
Menus 
Menus appear below the title bar on a Windows machine and at the top of 

your screen on a Mac. The majority of SketchUp tools, commands, and settings 
are available within these menus. The menus are: SketchUp (Mac only), File, 
Edit, View, Camera, Draw, Tools, Window, and Help. 

 
Toolbars 
The toolbars, appearing below the menus and along the left side of the 

Windows application, contain a user-defined set of tools and controls. By default, 
the toolbar contains the basic set of SketchUp tools, referred to as the getting 
started tools. Additional toolbars can be displayed by selecting the toolbars under 
the View > Toolbars menu item. 

 
Drawing Area 
The drawing area is where you create your model. The 3D space of the 

drawing area is identified visually by the drawing axes. The drawing axes are 
three colored lines, perpendicular to each other. These axes are helpful in 
providing a sense of direction in 3D space while you work. 
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The drawing area also contains a simple model of a person to give you a 

sense of 3D space. 
 
Status Bar 
The status bar is the long gray rectangular area at the bottom of the 

drawing area. 
The left side of the status bar contains buttons to geo-locate, claim credit, 

and sign in, respectively. The middle area contains a button to show the instructor 
and displays tips for the currently used drawing tools, including special functions 
accessible using keyboard shortcuts. Watch the status bar to discover advanced 
capabilities of each of the SketchUp tools. 

The Measurements Toolbar, located on the right side of the status bar, 
displays dimensional information while you draw. You can also enter values into 
the Measurements Toolbar to manipulate currently selected entities, such as 
creating a line of a specific length. 

To the right of the Measurements Toolbar is the window resize handle 
which is used to change the size of the application window and drawing area. You 
can also make the window larger so you can see the entire message in the status 
bar. 

 
Using the Mouse in SketchUp 

 
SketchUp can work with both 3-button and 1 button (commonly found on 

Mac computers) mice. A 3-button mouse is preferred as it will greatly increase 
your efficiency with SketchUp. You must learn different mouse operations before 
you can begin drawing in SketchUp. 

A three-button mouse consists of a left mouse button, a middle-mouse 
button (also called the scroll wheel) and a right-mouse button. The following is an 
overview of the different mouse operations commonly performed in SketchUp with 
a three-button mouse: 
- Click - A click refers to the user quickly pressing the releasing the left-mouse 

button. 
- Click and hold - A click and hold refers to the user pressing and holding down 

the left-mouse button. 
- Click, hold, drag - A click, hold, drag operation refers to the user pressing and 

holding down the left-mouse button and then moving the cursor. 
- Middle click, hold, drag - A middle click, hold, drag operation refers to the user 

pressing and holding down the middle-mouse button and them moving the 
cursor. 

- Scroll - A scroll refers to a user spinning the middle mouse wheel. 
- Context-click - A context-click refers to pressing and holding the right-mouse 

button. Context-clicks are usually used to display context menus. Context 
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menus are menus whose contents vary depending on the context in which 
they are invoked (usually on one or more entities in the drawing area or within 
a component, such as a dialog box). The following image shows a context 
menu for a Face entity. 

 
Viewing a Model in 3D Space 

 
SketchUp implements the concept of a camera to represent your point of 

view of the model. Simply, you (the user) are treated as though you were a 
camera looking at your model as you work. 

There are several tools in SketchUp for viewing your model in 3D space. 
The most commonly used camera tools are the Orbit tool, Pan tool, Zoom tool, 
and Zoom extents tool. 

Preparing to Use the Viewing Tools 
You must have a model in the drawing area before we can practice 

viewing. By default, SketchUp contains a model of a person at the origin of the 
axes. You can use that model for the purposes of these exercises. Or, follow 
these steps to place one of SketchUp's pre-built models into the drawing area: 
1. Click on Window > Components. The Component Browser is displayed. 
2. Click on the 'Collections and Searches' drop-down list identified by a 

downward arrow ( ). 
3. Click on the Architecture item. Architectural collections are listed. 
4. Click on one of the collections, such as "Furniture." The 3D Warehouse 

appears. 
5. Click on one of the collections, such as "Beds." Several components appear. 
6. Click on one of the pre-built architectural models, such as a "Twin size bunk 

bed." The Twin size bunk bed page appears. 
7. Click on the Download Model button. The Load into Model? dialog box 

appears. 
8. Click on the Yes button. The model appears in SketchUp attached to the 

Select tool. 
9. Click anywhere in the drawing area to place the model. The model will be 

positioned in the drawing area. 
 

Using the Orbit Tool 
 
Use the Orbit Tool to rotate the camera about the model and is often used 

while drawing to quickly change your view in between drawing operations. 
Activate the Orbit Tool from either the Camera Toolbar or the Camera menu. To 
orbit your model: 
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1. Click on the Orbit Tool (  ) in the toolbar. The cursor changes to two 

interconnected perpendicular ovals ((  ). 
2. Click anywhere in the drawing area. 
3. Move your cursor in any direction to rotate around the center of the drawing 

area. 
4. A 3-button mouse allows you to orbit a model without exiting the current 

drawing tool, speeding up your drawing. To orbit with a 3-button mouse: 

5. Click on the Pencil Tool ( ) in the toolbar. The cursor changes to a pencil 

( ). 
6. Click and hold the middle-mouse button. The cursor changes to the Orbit Tool 

cursor (  ). 
7. Move your cursor in any direction to rotate around the center of the drawing 

area (continue to keep your finger pressed on the middle mouse button). 

8. Release the middle-mouse button to return to the Pencil Tool ( ). The 

cursor changes back to a pencil ( ). 
 

Using the Pan Tool 
 
Use the Pan Tool to move the camera (your view) vertically and 

horizontally. Activate the Pan Tool from either the Camera Toolbar or the Camera 
menu. To pan using the Pan Tool: 

1. Click on the Pan Tool ( ). The cursor changes to a hand ( ). 
2. Click anywhere in the drawing area. 
3. Move the cursor in any direction to pan. 

A 3-button mouse allows you to pan your view without exiting the current 
drawing tool, speeding up your drawing. To orbit with a 3-button mouse: 

1. Click on the Pencil Tool ( ) in the toolbar. The cursor changes to a pencil 

( ). 
2. Press and hold the Shift key. 
3. Press and hold the middle-mouse button. The cursor changes to the Pan Tool 

cursor ( ). 
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4. (optionally) Press and hold the left mouse button while pressing and holding 

the middle mouse button (scroll wheel) to activate the Pan Tool. 
 

Using the Zoom Tool 
 
Use the Zoom Tool to move the camera (your view) in or out. Activate the 

Zoom Tool from either the Camera Toolbar or the Camera menu. 

1. Click on the Zoom Tool ( ) in the toolbar. The cursor changes to a 

magnifying glass ( ). 
2. Click and hold anywhere in the drawing area. 
3. Drag the cursor up to zoom in (closer to the model) and down to zoom out 

(farther from the model). 
A 3-button mouse allows you to zoom in or out without exiting the current 

drawing tool, speeding up your drawing. To zoom with a 3-button mouse: 

1. Click on the Pencil Tool ( ) in the toolbar. The cursor changes to a pencil 

( ). 
2. Roll the scroll wheel (middle-mouse button) forward to zoom in on your 

model. 
3. Roll the scroll wheel (middle-mouse button) back to zoom out from your 

model. 
 

Using the Zoom Extents Tool 
 
Use the Zoom Extents Tool to zoom your view to a distance where the 

whole model is visible and centered in the drawing area. Activate the Zoom 
Extents Tool from either the Camera Toolbar or the Camera menu. The Zoom 
Extents Tool is often used when your model goes off screen or you find yourself 

confused about the view of your model. Click on the Zoom Extents Tool ( ) in 
the toolbar. Your model is centered in the drawing area. 

 
Creating Geometry with the Push/Pull Tool 

 
Use the Push/Pull Tool to push and pull faces to add volume to or subtract 

volume from your models. You can use push/pull to create volume out of any face 
type, including circular, rectangular, and abstract faces. Activate the Push/Pull 
Tool from either the Toolbar or the Tools menu. 
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Preparing to Use the Push/Pull Tool 

 
Start a new file before continuing with the next exercise. To start a new file: 
Select File > New. A dialog box is displayed asking if you want to save your 

changes. 
Click on the No button. A new, blank, drawing area appears. 

Click on the Rectangle Tool ( ). The cursor changes to a pencil with a 

rectangle ( ). 
Click anywhere in the drawing area to set the first corner point of the 

rectangle. 
Move the cursor diagonally. A rectangle will expand out from the first corner 

point. 
 

 
 
Click again to set the second corner of the rectangle. A rectangular face is 

created bordered by four edges. 
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Using the Push/Pull Tool 

 
To push or pull a face: 

1. Click on the Push/Pull Tool ( ). The cursor will change to a 3D 

rectangle with an up arrow ( ). 
2. Click on the rectangular face created in the previous exercise. 
 

 
 
3. Move the cursor to create (or decrease) volume. 
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Press the Esc key at any point during the operation to start over. 
4. Click when the volume has reached the desired size. 
You can also press and hold the mouse button, drag the mouse, and 

release the mouse button to create a volume. 
You can use the Push/Pull Tool to create volume from any shape, whether 

it be an abstract shape drawn using the Freehand Tool or a shape drawn on 
another piece of 3D geometry. Following are some examples of Push/Pull 
operations. 

 
Pushing and Pulling a Curved Face 

 
You can use the Push/Pull Tool on faces that have an arc as an edge 

similarly to using the Push/Pull Tool on regular faces. The curved face that results 
from the push/pull operation is called a Surface entity. Surfaces can be adjusted 
as a whole, but are comprised of a number of faces or a curved face set. 

 

 
 
 

Creating Voids with Push/Pull 
 
You can create a void, or empty space, simply by drawing a 2D shape on 

3D geometry and using the Push/Pull Tool to push the 2D face until it meets the 
back face of the 3D geometry. The following three images demonstrate how to 
push/pull a 2D face that is drawn on 3D geometry to create a void. 
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Drawing Shapes with the Circle, Arc, and Rectangle Tools 
 
The majority of drawing tools in SketchUp, such as the Circle, Arc, and 

Rectangle Tool, are designed to speed up what can be drawn using the Pencil 
Tool. 
 

Drawing Circles 
 
Use the Circle Tool to draw circle entities. Activate the Circle Tool from the 

Toolbar or the Draw menu. To draw a circle:  

1. Select the Circle Tool ( ). The cursor changes to a pencil with a 
circle. 

2. Click to place the center point of the circle. 
3. Move the cursor out from the center point to define the radius of your 

circle. As you move the cursor, the radius value is displayed dynamically in the 
Measurements Toolbar and can be specified by typing in a length value followed 
by pressing the Enter (Microsoft Windows) or Return (Mac OS X) key. You can 
also specify the segmentation for the circle in the Measurements Toolbar. 
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Press the Esc key at any point during the operation to start over. 
4. Click to finish the circle. 
You can also click and hold the mouse button to set the center of the circle, 

and drag outward without releasing the button to set the radius. Release the 
mouse button to complete the circle.  

 
Drawing Arcs 

 
Use the Arc Tool to draw Arc entities, comprised of multiple line segments 

(which can be edited as a single arc). Activate the Arc Tool from the Toolbar or 
from the Draw menu. 

Arc entities consist of three parts: the starting point, the ending point and 
the bulge distance. The distance between the starting point and the ending point 
is also known as the chord length. To draw an arc: 

1. Select the Arc Tool ( ). The cursor changes to a pencil with an arc. 
2. Click to place the starting point of your arc. 
3. Move the cursor to the ending point of your chord. 
4. lick to place the ending point of your arc. A straight line is created. 
5. Move your cursor perpendicular to the straight line to adjust the bulge 

distance. A straight line will extend perpendicular from the straight line. 
 

 
 
Press the "Esc" key at any point during the operation to start over. 
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6. Click to set the bulge distance. 

 
Drawing Rectangles 

 
Use the Rectangle Tool to draw rectangular Face entities, specified by 

clicking at two opposite corners of the desired shape. Activate the Rectangle Tool 
from either the Toolbar or Draw menu. 

Rectangles can be placed on existing faces or separate from existing 
geometry (aligned to an axes plane). To draw a rectangle: 

1. Select the Rectangle Tool ( ). The cursor changes to a pencil with a 
rectangle. 

2. Click to set the first corner point of the rectangle. 
3. Move the cursor diagonally. Press the Esc key at any point during the 

operation to start over. 
4. Click again to set the second corner point of the rectangle. 
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