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ЗАГАЛЬНІ ВІДОМОСТІ 
 
Вивчення дисципліни «Геоінформаційні технології» передбачено 

програмою перепідготовки спеціаліста за спеціальністю 7.06010101 
«Промислове і цивільне будівництво». Відповідно до навчального плану обсяг 
курсу становить 2 кредити або 72 академічних години. Геоінформаційні 
технології передбачають обробку інформації в Геоінформаційній системі (ГІС), 
що являє собою комплекс, який включає програмно-апаратне забезпечення та 
набори даних. ГІС є засобом для обробки просторово розподіленої інформації, 
зокрема для введення, представлення, аналізу й виводу інформації в 
картографічному вигляді. Геоінформаційні технології використовують для 
інформаційної підтримки прийняття управлінських рішень. 

Програмне забезпечення геоінформаційних технологій класифікують за 
призначенням: інформаційно-довідкові, картографічні системи, настільні й 
промислові ГІС. А також за типами даних: векторні, растрові, універсальні. Під 
час організації моделей даних ГІС використовують позиційні дані (просторові), 
що визначають місце розташування об'єктів, та атрибутивні дані, що 
визначають тематичні та часові характеристики. Просторові дані можуть бути 
описані за допомогою векторних моделей, які утворюються точками 
(точковими об'єктами), лініями (полілініями, лінійними об'єктами) і полігонами 
(ареалами, майданними об'єктами). 

У результаті вивчення курсу студент повинен опанувати основні прийоми 
роботи з вікном Списку та вікном Карти, імпорту графічної інформації, 
створення атрибутивно-графічної бази даних, узагальнення, роз'єднання та 
комбінування таблиць. 

У процесі вивчення дисципліни «Геоінформаційні технології» студент 
має виконати контрольну роботу, що складається з 6 практичних завдань. У 
методичних вказівках наведені покрокові рекомендації з їх виконання. 

Вихідними даними є електронні файли, розташовані в папці DATA5K. 
Контрольну роботу потрібно виконати в терміни, передбачені навчальним 

графіком. У процесі виконання практичних завдань треба сформувати 
текстовий файл-звіт у форматі .doc, що містить завдання, відповідні пояснення 
та скрін-шоти результатів роботи. Наприкінці файлу необхідно привести список 
літератури, яку студент використовував під час виконання контрольної роботи. 
Текстовий файл-звіт повинен мати титульний аркуш, на якому треба вказати 
назву дисципліни, прізвище, ім'я та по батькові студента, курс, спеціальність і 
факультет. 

Контрольну роботу треба представити на перевірку у вигляді 
роздрукованого на паперовому носії файлу-звіту та електронної папки з 
таблицями й робочими наборами виконаних завдань. 
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ЗАВДАННЯ ДЛЯ КОНТРОЛЬНОЇ РОБОТИ 

 

Завдання 1 
Створення й редагування графічних даних 

 

1.1 Створення символів та графічних об'єктів 
� Накреслити об'єкти: дугу, еліпс, окружність, полігон, прямокутник та 

прямокутник з округленими кутами, кожний елемент розмножити й 
змінити його форму за допомогою додавання вузлів, зберегти модифікації 
кожного елемента в окремій таблиці. 
- Створити нову таблицю 

File > New Table; 
- у діалоговому вікні Table Structure сформувати дві колонки  

Num (коротке ціле) і Nazvanie (символьне 30); 
- задати проекцію Longitude/Latitude та зберегти таблицю з ім'ям 

Елементи; 

- використовуючи інструмент  Symbol, створити символ; 

- виділити символ інструментом  Стрілка та скопіювати його в 
буфер, потім вставити п'ять символів з буфера й розмістити їх на карті в 
довільному порядку; 

- використовуючи інструмент  Symbol Style, задати кожному символу 
форму та колір; 

- зберегти копію таблиці з ім'ям Символ у папці Zadanie1; 
- видалити символи з таблиці Елементи та з використанням інструменту 

 Лінія, накреслити пряму лінію; 

- використовуючи інструмент  Інформація, ввести її номер – 1 та 
найменування – Лінія; 

- зробити шар Елементи змінюваним та виділити лінію інструментом  
Стрілка; 

- натиснути інструмент  Reshape (Зміна форми), а потім інструмент 

 Add Node (Додати вузол); 
- для додавання вузла клацнути в потрібному місці лінії, утвориться 

вузол, його треба захопити й перемістити, лінія перетвориться на ламану. 
Виконати на отриманій ламаній ще кілька зламів; 

- накреслити ще п'ять прямих ліній і перетворити їх на ламані; 
- зберегти копію таблиці з ім'ям Ламана в папці Zadanie1; 
- виконати такі самі дії для дуги, еліпса, окружності, полігона, 

прямокутника й прямокутника з округленими кутами та зберегти таблиці з 
відповідними іменами. 
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1.2 Зміна географічних параметрів об'єкту 
� Задати нові географічні параметри об'єктів у таблицях Символ, Лінія, 

Дуга, Еліпс, Окружність. 
- Відкрити таблицю Символ і зробити шар Символ редагованим, у цьому 

режимі можна змінювати географічні параметри; 
- змінюючи вручну географічні параметри символів, розташувати їх один 

під одним за вертикаллю; 
- відкрийте послідовно інші таблиці та виконайте в них такі самі 

перетворення з об'єктами. 
� Збережіть робочий набір Елементи в папці Zadanie1. 

 

Завдання 2 
Масштабний ефект. Зміна проекції 

 

2.1 Настроювання масштабного ефекту Карти 
� Настроїти Карту Миру таким чином, щоб столиці країн були видні тільки 

під час наближення Карти. 
- Відкрити таблиці Grid15, Ocean, World, WorldCap, використавши 

команду 
File (Файл) > Open Table (Відкрити таблицю)...; 

- змінити порядок шарів на карті таким чином, щоб шар WorldCap був 

самим верхнім, скористуватися кнопкою  Керування шарами;  
- обрати оформлення для шару WorldCap 

Map (Карта) > Layer Control (Керування шарами) > Display; 
- у діалоговому вікні Display Mode встановити прапорець та обрати 

символ і його колір; 

- показати назви столиць, встановивши опцію  Lable у рядку 
WorldCap. Клацнути кнопку Lable і задати колонку Capital; 

- використовуючи кнопку Display, у діалоговому вікні WorldCap Display 
Options включити опцію Zoom Layering і вказати масштаб Карти, при якому 
шар WorldCap буде видний: Min Zoom = 0, Max Zoom = 20000; 

� Помістити в текстовий файл-звіт скрін-шоти вікон з віддаленою й 
наближеною Картою. 

� Зберегти робочий набір з ім'ям Масштаб в папці Zadanie2. 
 

2.2 Зміна проекції Карти 
� Змінити проекцію Карти Світу. 

- Відкрити таблиці Grid15, Ocean, World, WorldCap, виконавши команду 
File (Файл) > Open Table (Відкрити таблицю)...; 

- змінити режим вікна Карти (вибрати проекцію та одиниці виміру) 
Map (Карта)> Options (Режими); 

- у діалоговому вікні, що з'явилося, Map Options клацнути кнопку 
Projection (Проекція); 
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– у діалоговому вікні Choose Projection встановлена поточна категорія 
(Category) Projection of the World та проекція Robinson. Вибрати категорію 
Longitude/Latitude та проекцію Longitude/Latitude. 

� Помістити скрін-шот вікна Карти Світу в текстовий файл-звіт. 
� Змінити проекцію Карти Росії. 

- Відкрити таблиці Grid1 та Rus_Obl, виконавши команду 
File (Файл) > Open Table (Відкрити таблицю)...; 

- змінити проекцію Карти за допомогою команди 
Map (Карта)> Options (Режими); 

- вибрати категорію проекції Regional Equal-Area Projection і проекцію 
Equal-Area Projection (Asia). 

� Помістити скрін-шот вікна Карти Росії в текстовий файл-звіт. 
� Закрити таблиці без збереження. 

 

Завдання 3 
Імпорт графічної інформації. Реєстрація растрів. 

Робота з графічними об'єктами. 
 

3.1 Імпорт графічної інформації 
�  Імпортувати кожний шар файлу All.dxf в окрему таблицю: 

- шар 1 - будівлі, 
- шар 2 - двори, 
- шар 3 - квартали, 
- шар 4 - газони. 
Для цього скористуватися командою 

Таблиця(Table) > Імпорт...(Import). 
У діалозі Керування dxf-імпортом (рис. 1.1) у поле DFX Layers to Import 

(імпортувати шари DFX) треба обрати шар, а потім включити опцію Preserve 
DFX Blocks as Multy-Poligon Regions (Створити з блоків багатозв’язні області) і 
клацнути кнопку Projektion (Проекції), з'явиться діалог Choose Projection (Вибір 
проекції), рис. 1.2. 

 
 

Рис. 1.1 – Діалог  Керування dxf-імпортом Рис. 1.2 – Діалог Вибір проекції 
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У діалозі Choose Projection (Вибір проекції) вибрати категорію (Category) 
Non-Earth (План-схема) і проекцію (Category Members) Non-Earth (meters). 

У діалозі, що з'явився, Non-Earth Coordinate Bounds (Координатна 
система плану) задати координатну систему плану MinX=-10000, MaxX=10000, 
MinY=-10000, MaxY=10000, рис. 1.3. 

 

Рис. 1.3 - Координатна система плану 
 

У діалозі Flipping Geographic (Відбити образ) клацнути ОК. 
Повторити виконані операції для всіх шарів All.dxf, створюючи з кожного 

шару окрему таблицю. 
�  Вирізати з будинків внутрішні дворики, для цього: 

- змінити порядок шарів, зробивши шар Двори вище шару Будівлі; 
- зробити шар Будівлі редагованим; 

- вибрати будинок з двориком за допомогою інструменту  Стрілка; 
- зафіксувати цей об'єкт як змінюваний: 

Objekts (Об'єкти) > Set Target (Вибрати змінюваний об'єкт); 
- обрати дворик, що вирізується, за допомогою стрілки та завершити 
операцію: 

Objekts (Об'єкти) > Erase Outside (Видалити частину). 
�  Відредагувати графічні об'єкти, використовуючи функції географічного 

аналізу (використати Objekts (Об'єкти) > Combine..( Об'єднати) (для 
об'єднання), Objekts (Об'єкти) > Split... (Розрізати) та ін. (Erase – 
Стерти; Nodes – Вузли, Smooth - Згладити)); 

�  Оформити будівлі та дворики різними кольорами. Для цього вибрати 
різні стилі оформлення графічних об'єктів за допомогою операції 

Options (Настроювання) > Region Style (Стиль областей). 
�  Скрін-шот вікна отриманої Карти помістити в текстовий файл-звіт. 
�  Зберегти робочий набір Zadanie3 папці Zadanie3. 

 

3.2 Реєстрація растрів 
�  Відкрити та зареєструвати растри Дороги1.tif - Дороги4.tif: 

- у діалозі Do you want to simply display the image, or register it so that it will 
have geographic coordinates? відповісти Register; 

- зареєструвати растри за схемою, показаною на рис. 1.4; 
- перед реєстрацією зображення обрати Проекція - План-схема (метри); 
- внести контрольні точки растру, клацнувши кожну точку. Скористуватися 

команду New перед зазначенням нової точки. Растри мають однакові розміри. 
Початок координат у растрі знаходиться в лівому верхньому куті; 
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- настроїти зображення растрів (яскравість, контрастність, прозорість), 
зробити прозорими поля карт: 

Table (Таблиця) > Raster (Растр) > Adjust Image Styles ( Підстроювання 
зображення) > Transparent; 

 

Рис. 1.4 - Схема реєстрації растрів Дороги1.tif - Дороги4.tif 
 

� Скрін-шот вікна отриманої Карти помістити в текстовий файл-звіт. 
�  Створити нову таблицю ХарактерДорог: Проекція - План-схема (метри) 

з атрибутами: тип_дороги (Символьне 10), число_смуг (Коротке ціле) 
Назва (Символьне (70)) 

File > New Table > Create. 
�  Створити об'єкти – дороги на шарі ХарактерДорог за растровим 

зображенням, задаючи атрибути за допомогою інструмента  
Інформація. Для цього до карти Дороги1-Дорогі4 додати шар 
Характердорог і зробити його змінюваним. 

�  Зберегти таблицю ХарактерДорог. 
�  Зберегти робочий набір ХарактерДорог папці Zadanie3. 

 

3.3 Вибір контрольних точок з географічними координатами 
�  Відкрити та зареєструвати растр Карта.tif, використовуючи координати, 

що нанесені на рисунок. 
- Відкрити рисунок Карта.tif у програмі MS Office Picture Manager та 

визначити географічні координати контрольних точок: точка 1 (52°N; 24°E); 
точка 2 (48°N; 30°E); точка 3 (48°N; 36°E). Перевести координати з формату 
DMS (DMS: dd mm ss) у десяткові градуси DD (Decimal Degrees, DD: dd.ff), для 
чого скористуватися формулою: 

Decimal Degrees = Degrees + Minutes/60 + Seconds/3600; 
- зареєструвати растр в Mapinfo; 
- вибрати проекцію: 

Projection > Longitude / Latitude > Longitude / Latitude; 
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Дороги2 
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- внести контрольні точки растру, клацнувши кожну точку. Використати 
команду New перед вказівкою нової точки; 

- настроїти зображення растра - зробити прозорим поле карти: 
Table > Raster > Adjust Image Styles > Transparent. 

�  Зберегти таблицю Карта. 
� Зберегти робочий набір Карта папці Zadanie3. 
� Відкрити та зареєструвати растр Карта.tif з новим ім'ям, задаючи 

контрольні точки вибором їх координат у вікні Карти. 
- Скопіювати та перейменувати файл Карта.tif у КартаУкр.tif; 
- відкрити таблиці Uk_bound, City та City_Name, що представляють 

собою векторні карти, які відповідають растровому зображенню; 
- відкрити растровий файл КартаУкр.tif, MapInfo відкриє діалог 

Реєстрація зображення; 
- виконати команду, що включає спеціальний режим, який дозволяє 

вибирати контрольні точки безпосередньо у вікні відкритої Карти 
Table > Raster > Select Control Point from Map; 

- знайти у вікні Карти та на растрі будь-яку спільну точку, наприклад, 
місто, та вказати на цю точку у вікні Карти. З'явиться діалог Додати контрольну 
точку із значеннями координат широти й довготи точки на Карті; 

- дати точці ім'я, за яким її можна визначити (наприклад, назву міста). 
Координати положення точки на растрі мають нульові значення. Натисніть OK; 

- вибрати додану контрольну точку в списку у верхній частині діалогу 
Додати контрольну точку; 

- указати на відповідну точку в растровому віконці діалогу. На екран буде 
виведений діалог Змінити контрольну точку, у якому координати карти будуть 
обраними у вікні Карти, а координати растра вже не будуть нульовими, 
натисніть кнопку OK; 

- для вибору наступної контрольної точки натисніть кнопку New. 
� Зберегти робочий набір КартаУкр папці Zadanie3. 

 

Завдання 4 
Створення атрибутивно-графічної бази даних. 

З'єднання таблиць 
 

4.1 Створення атрибутивно-графічної бази даних 
�  Створити нову таблицю DomaMoi: 

File > New Table 
- у діалозі, що з'явився, встановити опцію Open New Mapper, рис. 1.5; 
Клацнувши кнопку Create, одержимо діалогове вікно New Table Structure 

(Створити структуру таблиці), у якому треба описати колонки таблиці (поля) та 
їхні властивості. Для створення нового поля треба використовувати кнопку Add 
Field. Найменування колонок уводити англійськими літерами. 

- Створити поля: NomerDoma, ChisloEtagey, ChisloGiltsov, ChisloLiftov, 
ElektrNagruzka, TypeSten, TypeZdanija, з урахуванням того, що в таблиці має 
бути поле, за значеннями якого будуть ідентифікуватися записи довідників; 
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- вибрати проекцію Проекція - План-схема (метри). Координатна система 
плану - як на рис. 1.3. Отримана таблиця не має рядків. 

 

Рис. 1.5 - Діалог створення нової таблиці 
 

�  Створити довідники для матеріалу стін і типу будівлі: 
- таблицю Матеріал стін з атрибутами (полями) TypeSten (Коротке ціле) і 

Naimenovanie (Символьне (20)); 
- таблицю Тип будівлі з атрибутами (полями) TypeZdanija (Коротке ціле) і 

Naimenovanie (Символьне (20)). 
Для цього виконати команду 

Файл (File) > Нова Таблиця (New Table). 
У діалозі обрати опцію Open New Browser (Показати Списком). Для цих 

таблиць не треба встановлювати опцію Table is Mappable (Можна приєднувати 
географічні об'єкти). 

- У довідники внести кілька записів. Нові записи додаються за допомогою 
команди: 

Edit (Виправлення) > New Row (Новий запис). 
�  Зберегти таблиці TypeSten та TypeZdania. 

�  Накреслити будівлі в таблиці DomaMoi, використовуючи інструмент  
Полігон. 
- Зробити шар DomaMoi змінюваним; 
- увімкнути об'єктну прив'язку (натисканням клавіші S після вибору 

інструменту малювання майданного об'єкту). У результаті в рядку стану 
ввімкнеться опція SNAP; 

- задати атрибути для кожної будівлі за допомогою інструменту  
Інформація, у тому числі використовуючи інформацію з таблиць TypeSten і 
TypeZdania. Атрибути будівель з'являться в таблиці DomaMoi. Перевірте, 
увімкнувши табличне подання таблиці DomaMoi 

Window > New Bowser Window. 
� Скрін-шоти Карти і таблиць помістити в текстовий файл-звіт. 
� Зберегти всі змінені таблиці в папці Zadanie4. 

 

4.2 З'єднання таблиць 
�  За допомогою опції Query (Запит) > SQL-select (SQL-запит) з'єднати 

довідники TypeSten та TypeZdania і таблицю DomaMoi. 
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- У рядку Select Columns (Вибрати колонки) встановити «зірочку» (всі 
колонки); 

- у рядку from Tables (З таблиць) вказати таблиці DomaMoi і TypeZdania; 
- у рядку where Conditon (З умовою) вказати умову 

DomaMoi.TypeZdanija = TypeZdania.TypeZdania; 
- рядки Group by Columns (Згрупувати за колонками) і Order by Columns 

(Порядок задати за колонкою) залишити порожніми; 
- у рядку into Table Named (Помістити в таблицю) вказати ім'я нової 

таблиці Sel1. Зберегти запит, для чого скористуватися кнопкою Save Template. 
�  Зберегти таблицю Sel1 у папці Zadanie4. 
�  Показати нову таблицю Sel1 у вікні Карти: 

Вікно (Window) >Нова карта (New Map Window). 

За допомогою інструмента  Інформація проаналізувати, які атрибути 
пов'язані з графічними об'єктами таблиці Sel1. Результати аналізу помістити в 
текстовий файл-звіт. 

�  Повторити дії для довідника TypeSten, помістити результат у таблицю 
Sel2. Зберегти запит у папці Zadanie4. 

� Скрін-шот вікна Карти й вікна Списку помістити в текстовий файл-звіт; 
�  Зберегти робочий набір Zadanie4 в папці Zadanie4. 

 

Завдання 5 
Узагальнення та роз'єднання даних. Комбінування таблиць 

 

5.1 Узагальнення даних 
� У таблиці World об'єднати дві європейські країни - Чехію й Словаччину. 

- Відкрити таблиці Ocean і World; 

- увімкнути назви країн Lyer Control >  Label; 

- наблизити Європу, використовуючи кнопку  Zoom-in; 
- зробити шар World змінюваним та виділити Чехію й Словаччину 

інструментом  Стрілка, використовуючи клавішу Shift; 
- об'єднати Чехію й Словаччину, для чого скористатися командою 

Objekts (Об'єкти) > Combine...( Об'єднати); 
- у діалоговому вікні Data Aggregation включити метод Value (значення) 

ввести значення Czechoslovakia. 
� Скрін-шот карти помістити в текстовий файл-звіт. 
� Об'єднати країни Шенгенського Договору (Німеччина, Бельгія, 

Нідерланди, Люксембург, Франція, Іспанія, Австрія), присвоїти назву 
Shengen, установивши розмір шрифту 18. 

� Скрін-шот карти помістити в текстовий файл-звіт. 
� Зберегти робочий набір ОбъедСтран в папці Zadanie5. 
� Закрити всі таблиці без збереження 

File > Close All, обрати Discard All (Ні для всіх). 
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5.2 Злиття в таблиці 
� Об'єднати об'єкти з таблиці Rus_obl за значеннями з поля terr 

(Абревіатури територій). 
- Відкрити таблицю Rus_obl; 
- скористатися командою 

Table (Таблиця) > Combine Objekts using Column...:( Злиття в таблиці); 
- у діалоговому вікні Data Aggregation вибрати колонку sum_1995 і 

встановити метод Sum; 
- знову створені об'єкти є обраними й перебувають у тимчасовій таблиці 

Query1, тому щоб їх зберегти в окремій таблиці відразу після злиття необхідно 
таблицю Query1 зберегти з новим ім'ям: 

Файл > Зберегти копію... 
- задати ім'я таблиці RusTerr. 
- закрити таблицю Rus_obl без збереження, щоб у ній не залишилися 

щойно отримані об'єкти. 
� Відкрити таблицю RusTerr і показати у вікні Карти отримані території, а у 

вікні Списку основну інформацію. 
- Увімкнути назви територій, що зберігаються в атрибуті terr; 
- скрін-шот карти помістити в текстовий файл-звіт; 
- орієнтуючись на назви територій, зафарбувати регіони різними 

кольорами; 
- скрін-шот карти помістити в текстовий файл-звіт; 

�  Зберегти таблицю RusTerr у папці Zadanie5. 
 

5.3 Районування (роз'єднання даних) 
� Здійснити районування - розділити об'єкти з таблиці World на групи за 

значенням з поля Continent. 
- Відкрити таблиці Ocean і World; 
- скористуватися командою 

Window > New Redistrict Window (Районування); 
- у діалоговому вікні New Redistrict Window у рядку Source Table 

(Таблиця-джерело) встановити World; 
- у рядку District Field (Поле групування) встановити Continent; 
- обираючи поля в групі Available Fields (Доступні поля), додати в групу 

Fields to Browse (Поля в списку) поля Continent, Count, Fill, Sum(Pop_1994). 
Одержимо таблицю, у колонці Fill якої позначені кольори відповідних 

груп на карті. 
- скрін-шот таблиці й карти помістити в текстовий файл-звіт; 

- використовуючи інструмент  Інформація, одержати інформацію про 
Росію й Туреччину. 

� Перенести Росію й Туреччину з однієї геогрупи в іншу. 

- Зробити шар World змінюваним та виділити об'єкт інструментом  
Стрілка; 
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- за допомогою інструментів  Set Target District (Змінюваний район) і 

 Assign Selected Objects (Додати до району) здійснити перенесення. При 
цьому треба обрати відповідні рядки в списку районів та об'єкти у вікні Карти. 

� Проаналізувати, як змінилася інформація у вікні Списку та дані для Росії 

й Туреччини шляхом використання інструменту  Інформація. 
� Зберегти таблицю World. 
� Зберегти робочий набір з ім'ям Районування у папці Zadanie5. 

 

Завдання 6 
Формування нових атрибутів таблиць 

 

6.1 Одержати нові атрибути шляхом перетворення атрибутів, що 
містяться в тій самій таблиці 

� У таблиці Adm_Cent обчислити темп зростання населення у відсотках. 
При цьому для введення виразу в поле Value (Значення) скористатися 
кнопкою Assist (Скласти). 

� У таблиці Rus_Obl обчислити частку міського населення в 1995 році. 
� З таблиці Rus_Obl вибрати області, населення яких перевищує 1,5 млн. 

чол та не перевищує 3 млн. чол. 
� У таблиці Rus_Obl обрати області, у яких понад половини населення 

становлять чоловіки. 
� Зберегти всі запити в папці Zadanie4. 
� Скрін-шоти отриманих таблиць помістити в текстовий файл-звіт. 

 

6.2 Формування графіки та атрибутів таблиці на підставі інформації 
з іншої таблиці 

� У таблицю World помістити інформацію про населення столиць з таблиці 
WorldCap. 
- Змінити структуру таблиці World, додавши поле Cap_Pop_W (Речовинне 

Decimal); 
- обновити поле Cap_Pop_W таблиці World за значенням з поля Cap_Pop 

таблиці WorldCap 
Table (Таблиця) > Update Column (Обновити колонку); 

- таблиці об'єднати (Join) за значеннями з полів Country обох таблиць або 
полів Capital цих таблиць. 

� Зберегти зміни в таблиці World. 
� Створити нову таблицю Сontinenty на підставі таблиці World. 

- Відкрити таблицю World; 
- зберегти копію таблиці World як World1 

File  > Save Copy As...; 
- відкрити таблицю World1; 
- видалити з таблиці World1 всі поля, окрім поля Сontinent 

Table (Таблиця) > Maintenance (Змінити) > Table Structure; 
- зберегти копію таблиці World1 з ім'ям Сontinenty; 
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- відкрити таблицю Сontinenty у новому вікні Карти; 
- видалити всі записи з таблиці Сontinenty, для цього: 

- зробити шар Сontinenty змінюваним; 
- потім скористатися командою 

Query > Select All From Сontinenty; 
- натиснути клавішу <Delete>; 

- упакувати таблицю Сontinenty 
Table > Maintenance > Pack Table, 

при цьому зберегти таблицю перед упакуванням; 
- змінити таблицю Сontinenty за допомогою команди 

Table > Combine Objects using Column, 
- у діалозі Combine Objects using Column (Об'єднати об'єкти, 

використовуючи колонки) у рядку Combine objects from table (Зібрати області з 
таблиці) вказати таблицю World1, у рядку Group objects by column (Групувати 
об'єкти за значеннями з колонки) задається поле (колонка), у нашому випадку – 
Continent, за якою буде провадитися злиття, у рядку Store results in table 
(Помістити результат в) вказати таблицю Сontinenty. Якщо задати поле, що 
утримує значення, які не збігаються ні для яких об'єктів (унікальні значення), 
то не буде створено жодного нового об'єкту; 

- у діалоговому вікні Data Aggregatoin (Узагальнення даних) ужити метод 
узагальнення Value, як показано на рис. 6. 

 

Рис. 6 – Діалог Data Aggregatoin (Узагальнення даних) 
 

� Зберегти таблицю Сontinenty у папці Zadanie6. 
� Внести назви континентів російською мовою, використовуючи 

інструмент  Інформація. 
�  Внести в таблицю Сontinenty тематичну інформацію: 

- змінити структуру таблиці Сontinenty - додати поля Naselenie 
(Речовинне), MinNaselenie (Речовинне), MaxNaselenie (Речовинне), 
PrirostNaselenie (Речовинне), PahotnyeZemli (Речовинне), ChisloStran (Коротке 
ціле) 
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Table > Maintenance > Table Structure; 
- обновити поле Naselenie таблиці Сontinenty, заповнивши його 

інформацією з поля Pop_1994 таблиці World 
Table > Update Column; 

- у діалоговому вікні Update Column вибрати в рядку Calculate 
(Обчислити) функцію узагальнення Sum, у рядку of – ім'я колонки Pop_1994. 

У пункті Calculate (Обчислити) якщо відновлення відбувається на 
підставі власних значень таблиці, MapInfo автоматично встановлює Value 
(Значення), якщо відновлення відбувається на підставі даних з іншої таблиці, то 
можна задати Value або одну з функцій узагальнення: Min, Average, Sum, Max, 
Count, Proportion Sum, WtAvg, Proportion Avg або Proportion WtAvg. 

- Оновити інші поля таблиці Сontinenty, використовуючи відповідні 
функції узагальнення, з огляду на те, що в таблиці World колонки Pop_Grw_Rt 
та Arable_Pct позначають темпи приросту населення й відсоток орних земель 
відповідно. 

� Проаналізувати отримані дані, порівнюючи інформацію в полях таблиць 
World та Сontinenty, перевірити правильність обчислень. 

� Показати таблицю Сontinenty у двох різних вікнах Списку, 
впорядкувавши інформацію: 
- за значеннями з поля Continent (за алфавітом); 
- за значеннями з поля Населення (за зростанням населення): 

Query (Запит) > Select...(Вибрати...); 
- у діалоговому вікні Select у рядку Sort Results by Column вказати ім'я 

відповідного поля. 
� Зберегти таблицю Сontinenty. 
� Зберегти робочий набір Сontinenty. 
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ДОДАТОК 1 
ХАРАКТЕРИСТИКА ФАЙЛІВ В MAPINFO  

 
Всі дані в MapInfo зберігаються в таблицях. Кожна таблиця складається з 

кількох файлів: 
файл *.tab  містить опис таблиці і є обов'язковим; 
файл *.dat  містить атрибутивні дані і є обов'язковим, файл даних може так 
само мати розширення: 

*.xls, якщо джерелом є електронна таблиця Excel, 
*.wks, якщо джерелом даних є електронна таблиця Lotus 1-2-3, 
*.dbf, якщо джерелом даних є таблиця dBase / FoxBase, 
*.txt, якщо джерелом даних є ASCII файл з роздільниками, 
*.bmp, *.tif або *.gif, якщо джерелом даних є растровий файл; 

файл *.map містить графічні дані; 
файл *.id  служить для зв'язку графічних об'єктів з атрибутивними даними; 
файл *.ind  містить індекси, які необхідні для швидкого пошуку в таблиці. 
 
 
 
 

ФОРМАТИ ПІДТРИМУВАНИХ РАСТРОВИХ ФАЙЛІВ 
 
MapInfo може підтримувати сім форматів растрових файлів: 

BMP, GIF, JPEG, PCX, SPOT, TARGA, TIFF. 
Максимальний розмір підтримуваного растрового зображення 

16000 x 16000 пікселів. 
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ДОДАТОК 2 
ТИПИ ДАНИХ MAPINFO 

 

Тип даних Опис Розмір, байт 

Коротке ціле Small Integer ± 32767 2 

Ціле  Integer ± 2147483647 4 

Речовинне  Float речовинне число 8 

Десяткове  Decimal речовинне число 8 

Символьне  String 
рядок символів (не більше 254 
символів) 

≤ 32767 

Логічне  Logical True / False або 1/0 2 

Дата  Data дата у форматі ММ/ДД/ГГГГ 4 
 

ДОДАТОК 3 
SQL-ЗАПИТИ 

 
SQL (Structured Query Language) - структурована мова запитів. Багато 

програмних пакетів, що працюють з базами даних, у тому числі й MapInfo, 
підтримують синтаксис команд SQL. 

За допомогою SQL-запитів можна 
- фільтрувати дані, обираючи рядки й колонки; 
- поєднувати кілька таблиць в одну; 
- створювати колонки, що обчислюються (колонки, значення яких 
обчислюються з використанням значень з інших колонок); 
- сортувати дані за числовим значенням або за алфавітом; 
- узагальнювати дані. 
 

СИНТАКСИС SQL-ЗАПИТУ 
англомовний варіант російськомовний варіант 

Select [список_обираних_стовпців] Вибрати колонки 
[список_обираних_стовпців] 

From [список_таблиць] з таблиць [список_таблиць] 
Where [умова] з умовою [умова] 
Group By [ім'я стовпця], [ім'я 
стовпця]…] 

згрупувати за колонками [ім'я 
стовпця], [ім'я стовпця]…] 

OrderBy [ім'я_стовпця [Desc], 
[ім'я_стовпця [Desc] ]…] 

порядок задати за колонкою 
[ім'я_стовпця [Desc], [ім'я_стовпця 
[Desc]]…] 

Into [ім'я_тимчасової_таблиці] і помістити в таблицю 
[ім'я_тимчасової_таблиці] 
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ДОДАТОК 4 
УБУДОВАНІ ФУНКЦІЇ MAPINFO 

 
Функції перетворення 

№ Функція Опис 

1 Asc (string_expr) Повертає код першого символу рядка string_expr. 

2 Chr$ (num expr) Повертає символ, що відповідає коду num_expr. 

3 Val (string_expr) 
Повертає чисельну величину, витягнуту з рядка 
string_expr. 

4 Str$ (expression) 
Повертає строкове подання числа, об'єкта або 
стилю expression. 

5 
StringToDate 
(date_string) 

Переводить рядок date_string у величину типу Дата. 

6 
NumberToDate 
(num_date) 

Повертає величину типу Дата, створену з величини 
num_date типу Ціле (num_date – восьмизначне ціле 
число у формі ГГГГММДД). 

 
 

Функції дати й часу 
№ Функція Опис 

1 CurDate ( ) Повертає поточне значення дати. 

2 Day (date_expr) 
Повертає з дати date_expr ціле число від 1 до 31, що 
відповідають номеру дня в місяці. 

3 Month (date_expr) 
Повертає з дати date_expr ціле число від 1 до 12, що 
відповідають номеру місяця в році. 

4 Weekday (date_expr) 
Повертає з дати date_expr ціле число від 1 до 7, що 
відповідає номеру дня тижня. 

5 Year (date_expr) 
Витягає з дати date_expr ціле число, що відповідає 
року. 

6 Timer ( ) Повертає кількість секунд. 
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Математичні функції 
Функція Опис 

Тригонометричні функції 

1 Cos (num_expr) Обчислює косинус (num_expr - чисельне вираження 
кута в радіанах). 

2 Sin (num_expr) Обчислює синус (num_expr - чисельне вираження 
кута в радіанах). 

3 Tan (num_expr) Обчислює тангенс (num_expr - чисельне вираження 
кута в радіанах). 

4 Acos (num_expr) Повертає арккосинус числа num_expr у радіанах. 

5 Asin (num_expr) Повертає арксинус числа num_expr у радіанах. 

6 Atn (num_expr) Повертає арктангенс числа num_expr у радіанах. 

Генерація випадкових чисел 

1. Rnd (list_type) Генератор випадкових чисел (list_type – ціле число, 
що задає режим випадкової послідовності). 

«Знакові» функції 

1 Abs (num_expr) Повертає абсолютне значення числа num_expr. 

2 Sgn (num_expr) Розпізнає знак числа num_expr, повертає 
-1, якщо num_expr < 0; 
0, якщо num_expr = 0; 
1, якщо num_expr > 0. 

Округлення 
1 Fix (num_expr) Повертає ціле число, отримане з цілої частини 

дійсного числа num_expr (відтинає дробову 
частину). 2 Int (num_expr) Округлення дійсного числа. Повертає найближче 
ціле, менше або дорівнюване num_expr. 

3 Round (num_expr, 
round_to) 

Округляє число num_expr із заданою точністю 
round_to. 

Інші функції 
1 Exp (num_expr) Обчислює значення експоненти. 
2 Log (num_expr) Обчислює натуральний логарифм. 

3 Minimum (num_expr, 
num_expr) 

Повертає найменше з двох заданих чисел. 

4 Maximum (num_expr, 
num_expr) 

Повертає найбільше з двох заданих чисел. 

5 Sqr (num_expr) Обчислює квадратний корінь. 
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Географічні функції 
№ Функція Опис 

1 Area (obj_expr, 
unit_name) 

Повертає площу графічного об'єкта obj_expr в 
одиницях виміру unit_name. 

2 Perimeter (obj_expr, 
unit_name ) 

Повертає периметр графічного об'єкта obj_expr в 
одиницях виміру unit_name. 

3 Distance (x1, y1, x2, y2, 
unit_name ) 

Повертає відстань між двома точками в одиницях 
виміру unit_name. 

4 ObjectLen (obj expr, 
unitname) 

Обчислює довжину об'єкта obj_expr типу «лінія» 
або «полілінія» в одиницях виміру unit_name. 

 
Строкові функції 

Функція Опис 

Перетворення регістра 
1 UCase$ (string_expr) Повертає рядок string_expr, перетворюючи всі 

літери на заголовні. 
2 LCase$ (string_expr) Повертає рядок string_expr, перетворюючи всі 

літери на рядкові. 
3 Proper$ (string_expr) Повертає рядок string_expr, перетворюючи всі 

перші літери слів на прописні, а інші - на рядкові. 

Пошук підрядку 

1 InStr (position, string, 
substring. 

Пошук у рядку string, починаючи з позиції position, 
substring) підрядку. Повертає позицію першого 
символу підрядку або 0, якщо підрядок не 
знайдений. 
Виділення підрядку 

1 Left$ (string_expr, 
 num_expr) 

Повертає ліву частину рядка string_expr, виділяючи 
num_expr символів з нього. 

2 Right$ (string_expr, 
num_expr) 

Повертає праву частину рядка string_expr, 
виділяючи num_expr символів з нього. 

3 Mid$ (string_expr, 
position, length) 

Повертає підрядок довжиною length, витягаючи 
його з вихідного рядка string_expr, починаючи з 
позиції position. 4 MidByte$ (string_expr, 

position, length) 
Витягає байти з рядка, що складається з 
двохбайтових символів (наприклад, Windows 
Japanese). 
Видалення пробілів 

1 LTrim$ (string expr) Видаляє пробіли на початку рядка string_expr. 

2 RTrim$ (string expr) Видаляє пробіли наприкінці рядка string_expr. 



 21 

Форматування 
1 Format$ (value, pattern) Повертає строкове подання числа value у заданому 

форматі pattern. 
2 FormatNumber$ (num) Форматування числа з використанням символів 

десяткової точки та роздільника тисяч, 
використовуваних системою (наприклад, додавання 
роздільника тисяч). 

3 DeformatNumber$ 
(numstring) 

Очищає рядок, що представляє число, від символів, 
що  форматують (numeric_string – строкова 
величина, наприклад, “12,345,678”). 

Визначення довжини рядка 
1 Len (expr) Повертає кількість символів у рядку expr або 

кількість байтів у змінній expr. 
Повторення символів 

1 Space$ (num expr) Повертає рядок, що складається з num_expr 
пробілів. 

2 String$ (num_expr, 
string_expr ) 

Будує рядок, повторюючи перший символ рядка 
string_expr num_expr разів. 
Порівняння рядків 

1 Like(string_expr, 
patternstring, 
escapechar) 

Повертає True або False, порівнюючи рядок 
string_expr з шаблоном pattern_string. escape_char – 
строковий вираз, що задає символ. 

2 StringCompare 
(string_expr, 
string_expr) 

Порівнює два рядки, з огляду на розходження 
рядкових та прописних символів, повертає 
-1, якщо код символу з першого рядка менший за 
код відповідного символу з другого рядка; 
0, якщо два рядки дорівнюють один одному; 
1, якщо код символу з першого рядка більший за 
код відповідного символу з другого рядка. 

3 StringCompareIntl 
(string_expr, 
string_expr) 

Порівнює два рядки, з огляду на особливості 
сортування для різних мов, повертає 
-1, якщо код символу з першого рядка менший за 
код відповідного символу з другого рядка; 
0, якщо два рядки дорівнюють один одному; 
1, якщо код символу з першого рядка більший за 
код відповідного символу з другого рядка. 

 
Для порівняння строкових значень використовується так само оператор 

Like. Під час порівняння строкових значень за допомогою оператора Like 
можна використовувати наступні службові символи: 

- символ «_» (відповідає одному символу); 
- символ «%» (відповідає будь-якій кількості символів). 
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Математичні оператори 
№ Оператор Опис 
1 + Додавання; ознака додатного числа 
2 - Вирахування; ознака від’ємного числа 
3 *  Множення 
4 / Ділення 
5 \ Цілочисельне ділення 
6 Mod Залишок від цілочисельного ділення 
7 ^ Зведення в ступінь 

 

Строкові оператори 
№ Оператор Опис 

1 + Конкатенація (додавання) рядків 
2 & Конкатенація (додавання) рядків 

 

Логічні оператори 
Оператор Опис 

1 AND Логічне І 
True AND True = True 
False AND True = False 
False AND False = False 

2 OR Логічне АБО 
True OR True = True 
False OR True = True 
False OR False = False 

3 NOT Логічне заперечення 
NOT True = False 
NOT False = True 

 

Просторові оператори 
№ Оператор Опис 

1 A Contains B Об'єкт A містить об'єкт B. 
2 A Contains Entire B Об'єкт A повністю містить об'єкт B. 

3 A Within B Об'єкт A утримується усередині об'єкта B. 

4 A Entirely Within B Об'єкт A повністю утримується усередині 
об'єкта B. 

5 A Intersects B Об'єкт A перетинає об'єкт B. 
 

Оператори порівняння 
№ Оператор Опис 

1 = Рівність 
2 <> Нерівність 
3 > Більш ніж 
4 < Менш чим 
5 >= Більше або дорівнює 
6 <= Менше або дорівнює 
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